@mtfumの技術ブログ

Carthage updateすると以下のエラーが。

Incompatible Swift version - framework was built with 4.2.1 (swiftlang-1000.11.42 clang-1000.11.45.1) and the local version is 4.2 (swiftlang-1000.11.37.1 clang-1000.11.45.1).

なんじゃいと思ったら、Swiftの新しいversionでコンパイルされているよと。

自分のXcode10ではSwift4.2で、最新だと思っていたから戸惑った。

Xcode10.1がリリースされていることを知らず、1ヶ月ほどを過ごした。

いつも検索するので、URLを残しておく。

正式にApp Storeからダウンロードするならここ

GM版をダウンロードするなら、このstackoverflowのURL(How to download Xcode DMG or XIP file?)からできそう。

このログへのコメント

コメントはありません